Announcement

Collapse
No announcement yet.

Google Play Games: Sign-In Failed. Also, Achievements Broken.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Google Play Games: Sign-In Failed. Also, Achievements Broken.

    Is there any reason why I'm receiving said error?

    I tried this:
    Backed up data and uninstalled VC.
    Sign out and back in to Google Play Games.
    Reinstalled and restored game data.

    To no available, I get said error.

    Also, the Connect Battle achievements on Play Games... are they broken? I got all but those two. I CLEARLY have beaten 5 battles in a day...

    Galaxy Note 9, running Android 9.0 (April 1st, 2019 security update).

    NOTE:I've tried dispatching an email, and recieved a canned mesage involving connection errors. Irrelevant to my issue.

    #2
    Hi AskaLangly! Sorry for the delayed response. Have you checked if you successfully uploaded your game data to an AteamID? To check, go to pf.ateamid.com and log in to your AteamID account. Go to Apps > Valkyrie Connect. If you've successfully uploaded your data, you should see your account's User ID that is linked to your AteamID account.

    With regard to Google Play Games achievement error, kindly reach out to Google's support team as they could assist you better on this matter.

    I hope this helps!

    Comment

    Working...
    X